#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\<input.{1,}?value="(.{1,}?)""
Local $sString = "<input value="1" style="width: 90%;" type="text"></th><th style="cursor: default;" class=" filter">" & @CRLF & _
"<input value="2" class="tooltip" style="font-size: 0.8em; width: 90%;" placeholder="Datum" title="Datumsfilter " & @CRLF & _
"Mögliche Operatoren: < | > | <= | >= | <> < | > | <= | >= | <> | .. " & @CRLF & _
"Beispiele: " & @CRLF & _
"2016 | 2016-03 | 2016-03-24 (nur Jahr[-Monat[-Tag]]) " & @CRLF & _
">2015-02 | <=2016-09-15 (ab/bis angegebenem Jahr[-Monat[-Tag]] inkl./exkl.)" & @CRLF & _
"2016-03..2016-04-15 (angegebener Bereich) " & @CRLF & _
"<>2016-03 (ungleich)" type="text">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")