$re = '/\<input.{1,}?value="(.{1,}?)"/';
$str = '<input value="1" style="width: 90%;" type="text"></th><th style="cursor: default;" class=" filter">
<input value="2" class="tooltip" style="font-size: 0.8em; width: 90%;" placeholder="Datum" title="Datumsfilter
Mögliche Operatoren: < | > | <= | >= | <> < | > | <= | >= | <> | ..
Beispiele:
2016 | 2016-03 | 2016-03-24 (nur Jahr[-Monat[-Tag]])
>2015-02 | <=2016-09-15 (ab/bis angegebenem Jahr[-Monat[-Tag]] inkl./exkl.)
2016-03..2016-04-15 (angegebener Bereich)
<>2016-03 (ungleich)" type="text">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);