import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^Message: \\K[^\\r\\n]+";
final String string = "Filename: dynamicFile.txt\n"
+ "Property: some property to neglect\n"
+ "Message: the message I want\n"
+ "Time: dynamicTime";
final String subst = "B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}