$re = '/(?m)^Message: \K[^\r\n]+/m';
$str = 'Filename: dynamicFile.txt
Property: some property to neglect
Message: the message I want
Time: dynamicTime';
$subst = "B";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;