#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(ftp|http)://.*?\.(jpg|png)"
Local $sString = "ahahahttp://www.google.com/a.jpg>hhdhdrgegrgerherhr b.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")