package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(ftp|http)://.*?\.(jpg|png)`)
var str = `ahahahttp://www.google.com/a.jpg>hhdhdrgegrgerherhr b.jpg`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}