const regex = /^[^_]+_([^_]+).*_([^_]+)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^_]+_([^_]+).*_([^_]+)$', '')
const str = `ASIA_JAP_TOKYO_201109`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}