$re = '/^[^_]+_([^_]+).*_([^_]+)$/';
$str = 'ASIA_JAP_TOKYO_201109';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);