const regex = /^[0-9]{1,3}\.[0-9]{1,2}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{1,3}\\.[0-9]{1,2}$', '')
const str = `/^[0-9]{1,3}\\.[0-9]{1,2}\$/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}