$re = '/^[0-9]{1,3}\.[0-9]{1,2}$/';
$str = '/^[0-9]{1,3}\\.[0-9]{1,2}$/
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);