re = /(?=(?!-)\d{4})\b\d{4,}\b/
str = '2014
1106 **2014** **9899**
**11500**
234-233-2014
234-234-1100
-1100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end