#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=(?!-)\d{4})\b(\d{4,})\b"
Local $sString = "2014" & @CRLF & _
"1106 **2014** **9899**" & @CRLF & _
"**11500**" & @CRLF & _
"" & @CRLF & _
"234-233-2014" & @CRLF & _
"234-234-1100" & @CRLF & _
"-1100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")