using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?!-)\d{4})\b(\d{4,})\b";
string input = @"2014
1106 **2014** **9899**
**11500**
234-233-2014
234-234-1100
-1100";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}