using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\|)(?!(?:NULL|[0-9]+)(?:$|\|))([^|]*)(?=$|\|)";
string substitution = @"$1";
string input = @"TEST|123NjyfjUghfLL|NULL|999|NULL DATA|TEST NULL|TEST|NULL";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}