import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(['\"])((?:\\w+[ .]*){1,2})\\1";
final String string = "Kids, you \"tried\" your \"best\" and you failed miserably. The \"lesson\" is, \"never try.\"\n\n"
+ "Just because I don’t 'care' doesn’t mean I don’t understand.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}