$re = '/([\'"])((?:\w+[ .]*){1,2})\1/m';
$str = 'Kids, you "tried" your "best" and you failed miserably. The "lesson" is, "never try."
Just because I don’t \'care\' doesn’t mean I don’t understand.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);