import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?is)(?:\\G(?!\\A)|\\A(?=.*\\bbank\\saccount\\b)).*?\\K\\b\\d{6,17}\\b";
final String string = "The bank account numbers are below:\n\n"
+ "Here's a bunch of numbers\n\n"
+ "8451358\n"
+ "1845962\n"
+ "12346584\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}