$re = '/(?is)(?:\G(?!\A)|\A(?=.*\bbank\saccount\b)).*?\K\b\d{6,17}\b/m';
$str = 'The bank account numbers are below:
Here\'s a bunch of numbers
8451358
1845962
12346584
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);