# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(.+) \b(?=.*\b\1)//gm;t' <<< "Mike Tyson 1. Street 1234 Vietnam ML(1234/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632)"