$re = '/\b(.+) \b(?=.*\b\1)/m';
$str = 'Mike Tyson 1. Street 1234 Vietnam ML(1234/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;