using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)[\s]*=[\s]*((?:[^""'\s]+)|'(?:[^']*)'|""(?:[^""]*)"")";
string input = @"key='value',
key=value,
key =""abcsa"",";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}