re = /(\w+)[\s]*=[\s]*((?:[^"'\s]+)|'(?:[^']*)'|"(?:[^"]*)")/
str = 'key=\'value\',
key=value,
key ="abcsa",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end