$re = '/\+>(?!<\+)([^<]*(?:<(?!\/\+)[^<]*)*)<\/\+/';
$str = '<+RecordID+>SWCR000111</+RecordID+><+Title+>My Title Is < Than > Yours</+Title+>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);