re = /\+>(?!<\+)([^<]*(?:<(?!\/\+)[^<]*)*)<\/\+/
str = '<+RecordID+>SWCR000111</+RecordID+><+Title+>My Title Is < Than > Yours</+Title+>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end