using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+).*?>(somethin)<\/\1>";
string input = @"<p src="" class="">somethin</p>
<p>nuthin</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}