$re = '/<(\w+).*?>(somethin)<\/\1>/';
$str = '<p src="" class="">somethin</p>
<p>nuthin</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);