const regex = /^(?:feat|fix|docs|style|refactor|perf|test|chore|revert)\(.+\).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:feat|fix|docs|style|refactor|perf|test|chore|revert)\\(.+\\).*', '')
const str = `feat(refinementList): Move default templates to its own file`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}