$re = '/^(?:feat|fix|docs|style|refactor|perf|test|chore|revert)\(.+\).*/';
$str = 'feat(refinementList): Move default templates to its own file';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);