using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\/\/\w+\/(\w+)\/(?=\1)";
string input = @"http://localhost/dir1/file1
http://localhost/dir1/dir1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}