$re = '/:\/\/\w+\/(\w+)\/(?=\1)/m';
$str = 'http://localhost/dir1/file1
http://localhost/dir1/dir1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);