import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?\\d{3}\\)?[ .-]?\\d{3}[ .-]?\\d{4}";
final String string = "Call me at 555-123-4567\n"
+ "My number is (555) 123 4567\n"
+ "5551234567\n"
+ "555.123.4567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}