$re = '/\(?\d{3}\)?[ .-]?\d{3}[ .-]?\d{4}/m';
$str = 'Call me at 555-123-4567
My number is (555) 123 4567
5551234567
555.123.4567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);