package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.|[^S\n].*|.[^H\n].*)\.csv`)
var str = `F.csv
SH.csv
RH.csv
ST.csv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}