$re = '/^(.|[^S\n].*|.[^H\n].*)\.csv/m';
$str = 'F.csv
SH.csv
RH.csv
ST.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);