const regex = /^(ATC02007)([0-9]{14})((?:[^.]*)?\.xls)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(ATC02007)([0-9]{14})((?:[^.]*)?\\.xls)$', 'gm')
const str = `ATC0200720140828080610.xls
ATC0200720140901080346_UFF_ACC.xls
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}