$re = '/^(ATC02007)([0-9]{14})((?:[^.]*)?\.xls)$/m';
$str = 'ATC0200720140828080610.xls
ATC0200720140901080346_UFF_ACC.xls
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);