using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)<a[^=]*=""[^\/]*\/([^\/]+\/)*(.*)"">.*";
string input = @"<!-- wikibase-toolbar --><span class=""wikibase-toolbar-container""><span class=""wikibase-toolbar-item wikibase-toolbar "">[<span class=""wikibase-toolbar-item wikibase-toolbar-button wikibase-toolbar-button-edit""><a href=""/wiki/Special:SetSiteLink/Q170596"">edit</a></span>]</span></span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}