re = /(.*)<a[^=]*="[^\/]*\/([^\/]+\/)*(.*)">.*/m
str = '<!-- wikibase-toolbar --><span class="wikibase-toolbar-container"><span class="wikibase-toolbar-item wikibase-toolbar ">[<span class="wikibase-toolbar-item wikibase-toolbar-button wikibase-toolbar-button-edit"><a href="/wiki/Special:SetSiteLink/Q170596">edit</a></span>]</span></span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end