package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w\d_]*?@[\w]*?\.[\w]{2,3}\.?[\w]?`)
var str = `Recipients: Unwanted_text alice@somedomain.com other junk bob@someotherdomain.com some.hostname.net 1 carl@carlsplace.org even-more`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}