$re = '/[\w\d_]*?@[\w]*?\.[\w]{2,3}\.?[\w]?/m';
$str = 'Recipients: Unwanted_text alice@somedomain.com other junk bob@someotherdomain.com some.hostname.net 1 carl@carlsplace.org even-more';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);