package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(TX(1[0-9]\d|[2-9]\d\d)-(1[0-9]\d\d\d\d|[2-9]\d\d\d\d\d))$`)
var str = `TX874-152268`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}