import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(TX(1[0-9]\\d|[2-9]\\d\\d)-(1[0-9]\\d\\d\\d\\d|[2-9]\\d\\d\\d\\d\\d))$";
final String string = "TX874-152268";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}