package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[a-zA-Z])(\w*)$`)
var str = `abc
i10n
10abc
abcабвгд
abc.3
Kfdjlkjdfgklj
w_87ew0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}