$re = '/(^[a-zA-Z])(\w*)$/m';
$str = 'abc
i10n
10abc
abcабвгд
abc.3
Kfdjlkjdfgklj
w_87ew0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);