#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<style[^>]*>([^<]+)?<[\s\/]+style>"
Local $sString = "<head>" & @CRLF & _
"<meta property="og:locale" content="en_US" />" & @CRLF & _
"<meta property="og:type" content="website" />" & @CRLF & _
"<style>html{line-height:1.15;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%;}</style>" & @CRLF & _
"<link rel='dns-prefetch' href='//js.stripe.com' />" & @CRLF & _
"<style id="pf-used-css">button,hr,input{overflow:visible;}[type="checkbox"],[type="radio"],legend{box-sizing:border-box;padding:0;}html{line-height:1.15;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%;}body,h1,h2,h3,h4,h5,h6{margin:0;}article,aside,details,figcaption,figure,footer,header,main,menu,nav,section{display:block;}hr{background-image:url("data:image/svg+xml;charset=utf-8,<svg viewBox=\"0 0 50 50\" height=\"24\" width=\"24\" xmlns=\"http://www.w3.org/2000/svg\" fill=\"%23B0B0B0\"><path d=\"M 9.15625 6.3125 L 6.3125 9.15625 L 22.15625 25 L 6.21875 40.96875 L 9.03125 43.78125 L 25 27.84375 L 40.9375 43.78125 L 43.78125 40.9375 L 27.84375 25 L 43.6875 9.15625 L 40.84375 6.3125 L 25 22.15625 L 9.15625 6.3125 z\"/></svg>");}.swal-label-required{display:inline-block;position:relative;right:9999px;margin-left:10px;}</style>" & @CRLF & _
"" & @CRLF & _
"<style>html{line-height:1.15;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%;}</style>" & @CRLF & _
"" & @CRLF & _
"</head>" & @CRLF & _
"<body>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")