import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<style[^>]*>([^<]+)?<[\\s\\/]+style>";
final String string = "<head>\n"
+ "<meta property=\"og:locale\" content=\"en_US\" />\n"
+ "<meta property=\"og:type\" content=\"website\" />\n"
+ "<style>html{line-height:1.15;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%;}</style>\n"
+ "<link rel='dns-prefetch' href='//js.stripe.com' />\n"
+ "<style id=\"pf-used-css\">button,hr,input{overflow:visible;}[type=\"checkbox\"],[type=\"radio\"],legend{box-sizing:border-box;padding:0;}html{line-height:1.15;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%;}body,h1,h2,h3,h4,h5,h6{margin:0;}article,aside,details,figcaption,figure,footer,header,main,menu,nav,section{display:block;}hr{background-image:url(\"data:image/svg+xml;charset=utf-8,<svg viewBox=\\\"0 0 50 50\\\" height=\\\"24\\\" width=\\\"24\\\" xmlns=\\\"http://www.w3.org/2000/svg\\\" fill=\\\"%23B0B0B0\\\"><path d=\\\"M 9.15625 6.3125 L 6.3125 9.15625 L 22.15625 25 L 6.21875 40.96875 L 9.03125 43.78125 L 25 27.84375 L 40.9375 43.78125 L 43.78125 40.9375 L 27.84375 25 L 43.6875 9.15625 L 40.84375 6.3125 L 25 22.15625 L 9.15625 6.3125 z\\\"/></svg>\");}.swal-label-required{display:inline-block;position:relative;right:9999px;margin-left:10px;}</style>\n\n"
+ "<style>html{line-height:1.15;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%;}</style>\n\n"
+ "</head>\n"
+ "<body>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}