re = /^(?!.*\..*\.)(\d+\.\d+)/m
str = 'These
111.111
Not these
111..110....11
11.11.11.11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end