using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(""+[A-Z_]+\""";
string input = @"balba.localise(""_THE_STRING_TO_LOCALISE"", null);";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}