using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<iframe.+?src=""https?:\/\/www\.youtube\.com\/embed\/([a-zA-Z0-9_-]{11})""[^>]+?><\/iframe>$";
string input = @"<iframe width=""560"" height=""315"" src=""https://www.youtube.com/embed/wRqjJ7SENDI"" frameborder=""0"" allowfullscreen></iframe>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}