using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"QUILLIVANT.+?(?=QUILLIVANT|$)";
string input = @"blahblahblah Quillivant 40MG derp derp derp Quillivant 60MG/5ML Syrup durka durka durka";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}